Inicio > Linux > Reparar compiz en Ubuntu 10.04 LTS luego de actualizacion

Reparar compiz en Ubuntu 10.04 LTS luego de actualizacion

miércoles, 19 de octubre de 2011

Ayer me salieron varias actualizaciones de paquetes en Ubuntu 10.04 LTS, entre esas unas del servidor X, luego de instalarlas no tenía problema, pero con el reporte de un amigo reinicié y me pasaba los mismo que a él, que los efectos gráficos del compiz no funcionaban. En la pantalla de Apariencia salían los efectos desactivados y al intentar activarlos luego de buscar controladores sale un error.

Si intentaba iniciar compiz manualmente (compiz –replace) salía el siguiente error:

compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Como a ambos nos pasaba el problema me meti al foro de Ubuntu hallando que es un problema de todos los que actualizaron quienes tengan esta versión de Ubuntu y no usen los drivers de NVIDIA.

La solución es downgradear los paquetes xserver-common y xserver-xorg-core con los siguientes comandos

sudo aptitude install xserver-common=2:1.7.6-2ubuntu7
sudo aptitude install xserver-xorg-core=2:1.7.6-2ubuntu7

Al proponer hacer downgrade poner Y.

Ahora para evitar que vuelvan a la ultima versión la próxima vez que instales actualizaciones debes bloquearlos en su versión actual, para eso en una consola de root (sudo -s) ejecutar

echo xserver-common hold | dpkg --set-selections
echo xserver-xorg-core hold | dpkg --set-selections

Cuando se puedan volver a actualizar para desbloquearlos ejecutar los comandos anteriores sustituyendo hold por install, o poner apt-get install nombre.

Finalmente reiniciar y activar los efectos de nuevo desde el panel de apariencia.

Tema foro ubuntu (fuente comando aptitude): http://ubuntuforums.org/showthread.php?t=1864489

Reporte de bug (si tienes cuenta puedes marcar que tambien te afecta a ti): https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/877905

Categories: Linux Tags: , , ,
  1. Jose
    miércoles, 19 de octubre de 2011 a las 21:01 | #1

    Estuve buscando solución toda la mañana y tarde. Ya faltándome poco para estallar encuentro tu página.
    Me salvas la vida y en verdad te agradezco la información.
    Ahora otra vez en calma…. 😀

  2. patz
    miércoles, 19 de octubre de 2011 a las 23:43 | #2

    y con este articulo te haces de un nuevo lector 😀
    mil gracias

  3. Marcelo Salgado
    miércoles, 19 de octubre de 2011 a las 23:56 | #3

    Muchisimas gracias por la solucion !
    Despues de estar intentando horas como reparar el problema originado justamente despues de una actualizacion, encontre tu foro y puede echar a andar de nuevo el compiz.

    Hay un pequeño detalle que quizas podria ayudar a otras personas. Al principio no funciono del todo. Borre por completo el xserver-xorg-core y luego procedi con las instrucciones que suministras. Al reiniciar volvio todo a la normalidad.

    Hay mucha gente que tiene este problema. Ojala tengan oportunidad de mirar este foro, ya que uno pierde horas tratando de arreglar este bug.

  4. Marcelo Salgado
    jueves, 20 de octubre de 2011 a las 00:46 | #4

    Hola otra vez. Para difundir la solucion, me permiti escribir en el foro de Debian
    (http://forums.debian.net/viewtopic.php?f=5&t=65617&p=399387#p399387)
    , en donde mucha gente reporta este problema, y reproduje el procedimiento de arriba (pero con los comentarios en ingles). De cualquier manera, puse la liga a esta pagina para que consulten las instrucciones tal como aparecen aqui.

  5. Carlos Giménez
    jueves, 20 de octubre de 2011 a las 08:31 | #5

    Excelente tu solución, muchas gracias. Actualicé ayer y se me rompió compiz, suponía que había que ir hacia atrás, pero no me daba cuenta como hacerlo.
    Otra vez gracias y como dijiste más arriba, un nuevo lector.
    Saludos

  6. Mudanzas Barcelona
    martes, 15 de noviembre de 2011 a las 12:23 | #6

    Vaya, muchas gracias por el aporte

  7. Psiquiatra Dr. Vallejo en barcelona
    martes, 15 de noviembre de 2011 a las 12:23 | #7

    Gracias por tu solución

  8. malpas Internet Technologies
    lunes, 23 de enero de 2012 a las 07:31 | #8

    Muchas gracias por la solución

Comentarios cerrados.